Problemi coi repository? Ci pensiamo noi!!!

sabato 16 ottobre 2010 a 10:40
In alcuni casi può capitare di avere problemi con i repository o di cancellarne qualcuno per sbaglio o addirittura di cancellarli tutti. Il nostro intento, oggi, è quello di ripristinare quelli base che vengono con Ubuntu out-of-the-box. Quello che sto per illustrarvi si può fare tramite interfaccia grafica, ma in questo caso penso che la shell sia il metodo più veloce:
aprite il terminale, quindi, e digitate
sudo gedit /etc/apt/sources.list
quindi ora vi si aprirà l'editor di testo gedit per modificare il file; se volete ripartire da capo cancellate tutto e lasciate solo i seguenti:

deb http://it.archive.ubuntu.com/ubuntu/ lucid main restricted
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://it.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://it.archive.ubuntu.com/ubuntu/ lucid universe
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid universe
deb http://it.archive.ubuntu.com/ubuntu/ lucid-updates universe
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb http://it.archive.ubuntu.com/ubuntu/ lucid multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://it.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb http://it.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
deb http://archive.canonical.com/ubuntu lucid partner
#deb-src http://archive.canonical.com/ubuntu lucid partner
deb http://security.ubuntu.com/ubuntu lucid-security main restricted
#deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
#deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
#deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://archive.ubuntu.com/ubuntu/ lucid-proposed restricted main multiverse universe

Spero di non averne dimenticato nessuno.... quindi un bel
sudo apt-get update
e via ad installare quello che più vi piace

4 commenti

  1. Anonimo Says:

    grazie.....per me è utile !!

  2. Anonimo Says:

    Caro AlucarD premetto... ho un computer Olidata di 10 anni fa, Ubuntu 9.04 e non posso passare alla versione 10.10 perché non me lo permette. per fare update "normali" mi arriva questo messaggio:"Impossibile inizializzare le informazioni del pacchetto

    Si è verificato un problema irrisolvibile durante l'inizializzazione delle informazioni del pacchetto.

    Segnalare questo bug per il pacchetto «update-manager» e includere il seguente messaggio d'errore:

    'E:La linea 55 in /etc/apt/sources.list (dist parse) non è corretta, E:La lista dei sorgenti non può essere letta.'" io vorrei tanto correggere questo problema... spero tu sappia aiutarmi... ho cercato in tutti i modi non so più che santi chiamare...

  3. Free_alucarD Says:

    chiedo al mio socio... io onestamente non saprei perchè dovrei essere li XD controlla la riga 55 che sia molto simile alle altre (se ho capito bene)
    anche io vado un pochino in pallone con certi errori... non mi capitano quasi mai però...

  4. Free_alucarD Says:

    ah comunque ti consiglio di aggiornare formattando... viene un lavoro molto più pulito e funzionale!

Posta un commento